[Pachi] Compiling pachi with cygwin

Petr Baudis pasky at ucw.cz
Wed Nov 6 19:00:21 CET 2013


  Hi!

On Wed, Nov 06, 2013 at 11:42:57AM -0600, Erik S. Steinmetz wrote:
> I am trying to compile pachi (the current version from the git repository) using cygwin. I try a plain old make without modifying the Makefile, and the program compiles and links (with many, many warnings), but when I start it up and tell it to ‘genmove b’, it seems to make it all the way through its thought process and then hangs.
> 
> I noticed that there was a thread about this back in January/February of 2012 on the computer-go mailing list, but it did not appear to end with a definitive solution.
> 
> Was there ever a solution found for this issue?

  In that thread, Michael Williams offered this advice:

> (When I said "latest", I meant latested released version -- 9.01)
> When compiling with MinGW, one must use at least the version from Jan 22,
> 2012.  And that is working for me.  I am able to compile and run.

  What about it?

  It seems the core issue is that cygwin per se does not support
pthreads properly.

				Petr "Pasky" Baudis


More information about the Pachi mailing list